Anteriormente Google se había propuesto a mejorar las aplicaciones de Android y les exigió apuntar an a un cierto nivel de API para aprovechar las nuevas características de la plataforma.

Ahora, con aplicaciones nuevas y actualizadas, Google informó sobre los requisitos de soporte de Pie (Android 9) establecidos para este año.

A partir de agosto, se requiere que toda nueva aplicación enviada para la Play Store deba alcanzar el nivel de API 28 y superior. Por otra parte, desde noviembre, las actualizaciones de las aplicaciones existentes también tendrán que ser compatibles con Android 9.

Las únicas apps que no se verían afectadas serían aquellas en la PlayStore que no reciben actualizaciones.

Además de Google Play, las tiendas de aplicaciones chinas como Huawei, OPPO, Vivo, Xiaomi, Baidu, Alibaba y Tencent requieren que los desarrolladores alcancen el nivel de API 26 en 2019.

Google señaló además que más del 95% del software espía detectado fuera de Play Store apunta al nivel de API 22 o inferior para evitar los permisos de tiempo de ejecución.

Para proteger a los usuarios del malware y para apoyar esta iniciativa de ecosistema, Google Play Protect avisará a los usuarios cuando intenten instalar un APK desde cualquier origen que no se dirija a un nivel de API reciente:

  1. Agosto de 2019: Las nuevas aplicaciones recibirán advertencias durante la instalación si no se dirigen al nivel de API 26 o superior.
  2. Noviembre de 2019: Las nuevas versiones de las aplicaciones existentes recibirán advertencias durante la instalación si no alcanzan el nivel de API 26 o superior.
  3. 2020 en adelante: El requisito de nivel de API objetivo avanzará anualmente.